概要

Linux Bean を起動すると、細かいモザイクもどき+縦線が入っている異常画面が表示されてしまい、そこから先に進めない。

恒久策の候補を色々と試したが、起動できるようになっても解像度が1027×768より上には上がらないなどの副作用があったりで、断念。
回避策としては、いったんモザイク画面になってしまったあとでも再起動すると、今度はなぜかうまく起動できる。
というわけで、起動したらいったん再起動するという運用で回避していこうと思う。

追記

はじめは、上記のように電源ボタンで再起動さえすれば直ってたのに、いつからかそれだけでは直らなくなってしまった・・・。
残された早めの起動方法としては、いったんOSをRecovery モードで起動してから、そっからResume でいったん低解像度のGUIの画面に入って、そこでOS再起動をかけること。
なんか、チップが暖まんないとグラフィックがうまく動かない、、、。そんなイメージ(*_*)

詳細

環境

  • PC:DELL INSPIRON 1501
  • グラフィック:内臓のATI Radeon Xpress 200
  • BIOS Ver.:2.6.3(最新)
  • OS:Linux Bean 14.04

症状

Linux Bean を起動すると、、細かいモザイクというか薄い色の細かいドットが散らばったような、かつ縦線が何本か入ったような画面が表示されてしまい、そこから先に進めない(*_*)

最終的な回避策

モザイク画面になってしまったときに、電源ボタンで強制的にシャットダウンする。このあと再起動すると、今度はなぜかうまく起動できる。解像度は期待通りの1280×800になる。
また、モザイク画面のまま15分くらい放置しておいても、なぜかいつの間にか起動しており、解像度も問題ない。
いったんうまく起動すれば、OSから再起動をかけたときにもうまく再起動を完了できる。
その後PCをシャットダウンしてからしばらく時間が経ったり、ACとバッテリーをいったん外してから起動し直すと、またモザイク画が出現してしまう。そのときはまた、電源ボタンでシャットダウンしてから起動すればよい。

追記

はじめは、上記のように電源ボタンで再起動さえすれば直ってたのに、いつからかそれだけでは直らなくなってしまった・・・。
残された早めの起動方法としては、いったんOSをRecovery モードで起動してから、そっからResume でいったん低解像度のGUIの画面に入って、そこでOS再起動をかけること。
なんか、チップが暖まんないとグラフィックがうまく動かない、、、。そんなイメージ(*_*)

改善できなかったり副作用が出てしまったパターン

色々試したけど諦めたパターンたち

AMD(ATI)のグラフィックドライバー群(fglrxまたはfglrx-updates と、その一群)をインストール

⇒ 起動時にモザイク画は出なくなった。ただし、解像度の限界が1024×768 になってしまう。解像度をあげようにも、それ以上の解像度が選択できない。
このとき、Catalyst Control Center を起動してみたら、そもそもグラフィックデバイスを認識できていないようだった。

nomodeset で起動

/etc/default/grub の中でGRUB_CMDLINE_LINUX_DEFAULT=”nomodeset” にしてsudo update-grub を実行。
⇒ 起動時にモザイク画は出なくなった。ただし、解像度の限界が1024×768 になってしまう。

/etc/X11/xorg.conf 編集

そもそもこの場所にxorg.conf が無かったため、ここで解像度を直すこともできなかった。

起動時に遅延するようにする

/etc/default/grub でGRUB_HIDDEN_TIMEOUT を0から60に変えて、起動を遅延させてみた。
⇒ 遅延するだけで特に効果なし。

BIOSで”High Precision Event Timer” をONにする。

⇒ 余計に悪化。起動時に常にモザイク画になってしまう。
つまり、シャットダウン後にすぐ起動しなおせばうまく起動できるという回避策さえ効かなくなってしまう。

所感

ネットを見ると、多くの人が似たような環境で似たような症状に遭遇している模様。
そこでは、nomodeset が解決の決定打として多く見られた。でもそれだと少なくとも私の環境では解像度が下がってしまうという副作用に見舞われた(・・)
解像度は下げたくなかったので、仕方なくいったんシャットダウンするという運用回避でいくことにした。
強制シャットダウンなんて本当はディスクによくないんだろうけど・・・^^;

追記

少し経ったら電源ボタンによる再起動でも直らなくなった、、、。いったんRecoveryモードに入ってからのOS再起動では直るけど、かなりめんどくさい、、、(*_*)

広告